Missing license DLL error with Roaming Profile

  Printer Drivers

Description:
Domain User with roaming profile gets a “Missing license dll” warning message after logon. The previously successfully registered Black Ice Printer Driver becomes unregistered and the “Register” button becomes active in Printer Manager. The Domain User cannot print with the Printer Driver.

Cause of the problem:
The “Missing license dll” problem occurs, if the configured Domain User has an incorrect roaming profile (the given Domain User has no rights to write to the shared folder where the roaming profile is stored). In this case, when the user tries to log in with the incorrect roaming profile, the server logs the domain user into a temporary system profile, and the Printer Driver becomes unregistered.

Solution:
After properly configuring the roaming profile shared folder (granting proper access to the domain user to write into the shared folder), log into the domain with the roaming profile again. The Printer Driver registration will be restored.

1. In order to resolve the problem, please make sure that the roaming profile shared folder is configured properly in the Active Directory.

2. Also, please make sure that the user has sufficient rights to write into the roaming profile directory.

Regards,
Technical Support Team