Printer installed, but driver not found

Black Ice Printer Driver related questions

Moderator: Technical Support Team

Printer installed, but driver not found

Postby ngasnier » Fri Dec 30, 2005 4:59 am

Hi,

I'm creating a custom printer installation to ship with our product with Install Shield Express 11. I have a custom .EXE action that call dInstallBlackIcePrinter function. The function seems to work well, because there is no error code returned. My printer shows in Windows's printer panel, but when I try to open the printer properties, Windows tells me that the driver "Pilote impression Gedisoft" is not installed. Therefore I cannot access the printer options dialog.
I've checked that all required DLLs and INI files are in the right place, correctly renamed. I've also checked in the registry if the keys were here and everithing seems fine, but I keep getting this error.

Here are the parameters passed to the install function :

[code]lExitCode = dInstallBlackIcePrinter(
"GEDiniNT.ini", /* DRIVER_CONFIG_INI */
"GEDDrvNT.dll", /* DRIVER_FILE, */
"GEDMonNT.dll", /* MONITOR_FILE */
"Gedisoft monitor", /* MONITOR_NAME */
"GedisoftPort:", /* PORT_NAME */
"GEDProNT.dll", /* PROCESSOR_FILE */
"Processeur Gedisoft", /* PROCESSOR_NAME */
"GEDResNT.dll", /* RESOURCE_DLL */
"GEDUifNT.dll", /* USER_INTERFACE_NAME */
"Imprimante Gedisoft", /* PRINTER_NAME */
"Pilote impression Gedisoft", /* DRIVER_NAME */
"Tiff32.dll", /* TIFF_DLL */
"JPEG32.dll", /* JPEG_DLL */
0)) /* DRIVER_TYPE*/ [/code]

Any advice on what I am doing wrong ?
ngasnier
 
Posts: 2
Joined: Fri Dec 30, 2005 3:30 am

Postby TechnicalSupportTeam » Sat Jan 21, 2006 11:02 am

Please ensure that you are installing your custom printer driver on the local machine (not through a remote connection) and that you are installing as a user with administrative privileges.

What operating system and service pack are you installing on?
Are you able to reproduce this issue using the unmodified, compiled installation provided by Black Ice?
Are there any other virtual printer drivers installed on the system?
TechnicalSupportTeam
 
Posts: 1005
Joined: Sat Mar 20, 2004 11:50 am

Postby ngasnier » Mon Jan 23, 2006 2:42 am

Well I think it is related to the renaming of the dlls to install my custom printer, because I've done the same install with the default dll names and it worked.

I have administrative privileges, and I hve tried on windows 2000 Pro and XP Pro SP2. I have tried with the default printer installed, and without, the result is the same.
ngasnier
 
Posts: 2
Joined: Fri Dec 30, 2005 3:30 am

Postby TechnicalSupportTeam » Sat Feb 11, 2006 9:24 am

make sure that in the driver's ini file you have specififed the new name for the resource DLL
TechnicalSupportTeam
 
Posts: 1005
Joined: Sat Mar 20, 2004 11:50 am


Return to Printer Drivers



Who is online

Users browsing this forum: Bing [Bot] and 4 guests